Status
Get in touch
Back
Resolved
EU Email Sending — Down
Started 17 Feb at 12:06am GMT.
Affected services
Emails
Created
AWS SES Resolved
Posted 17 Feb at 12:06am GMT.