Get in touch
Back
Maintenance

US Database maintenance

Completed 13 Feb at 07:53am GMT.

USA Web Apps
Completed

The update has been completed successfully.

Posted 13 Feb at 07:53am GMT.
Started

This Sunday between 8AM-10AM GMT we will be performing a scheduled maintenance upgrade to our US database systems. Access to Fliplet Studio and Fliplet web apps for US customers may be affected for a short period of time.

Posted 13 Feb at 07:00am GMT.