Get in touch
Back
Maintenance

Email sending delayed

Completed 28 Jan at 06:10pm GMT.

Emails
Updated

We have fully restored email service.

Posted 28 Jan at 06:18pm GMT.
Completed

Maintenance completed

Posted 28 Jan at 06:10pm GMT.
Started

We have managed to restore partial service, however we are still being heavily limited by our email provider. This means emails may be held and delayed.

Posted 28 Jan at 10:00am GMT.